-
Notifications
You must be signed in to change notification settings - Fork 887
feat: add database support for dismissed healthchecks #10845
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Changes from 5 commits
78e6c4d
7c024f6
c4829fb
13dc374
57977d8
47aad8f
502dbc8
8990cb0
e87215b
File filter
Filter by extension
Conversations
Jump to
Diff view
Diff view
There are no files selected for viewing
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Should we coalesce this to
[]
?There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I thought about it. There is one drawback of this approach: with
[]
we will close the structure for extra properties since it will accept only array items. I'm happy to change it to[]
if you think that it is fair.There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I mean, we could also coalesce it to
{}
and then start off with{"dismissed": [...]}
if you want to keep it open. My main point here was to avoid downstream consumers having to deal with a potentialnil
.There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yes, this will be open. Should I rename it to
health_settings
instead? (orhealthpage_settings
,healthcheck_settings
)There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
👍 Sounds good, I could imagine other persistent health-related site configs going in there.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Alright, converted it into
health_settings
with default value{}
. The API implementation will be similar to theServiceBanner