Thanks to visit codestin.com
Credit goes to github.com

Skip to content

bpo-29302: Implement contextlib.AsyncExitStack. #4790

New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Merged
merged 1 commit into from
Jan 25, 2018

Conversation

Kentzo
Copy link
Contributor

@Kentzo Kentzo commented Dec 11, 2017

This change is entirely based on the work of @thehesiod discussed at https://bugs.python.org/issue29302

I only changed implementation of __aexit__:

except BaseException as e:
    gen.throw(e)

to:

except:
    gen.throw(*sys.exc_info())

and added tests.

https://bugs.python.org/issue29302

@thehesiod
Copy link
Contributor

thanks @Kentzo !

@asvetlov asvetlov requested a review from 1st1 December 11, 2017 07:16
@Kentzo Kentzo changed the title bpo-29302: Implement contextlib.AsyncContextManager. bpo-29302: Implement contextlib.AsyncExitStack. Dec 11, 2017
@Kentzo Kentzo force-pushed the bpo-29302 branch 2 times, most recently from 4374de3 to 60000cd Compare December 11, 2017 23:17
@1st1 1st1 requested a review from ncoghlan December 11, 2017 23:35
@ncoghlan
Copy link
Contributor

ncoghlan commented Dec 14, 2017 via email

@ncoghlan
Copy link
Contributor

ncoghlan commented Dec 14, 2017 via email

@1st1
Copy link
Member

1st1 commented Dec 14, 2017

@1st1 I'd like to take a further look at this one before we merge it, but
won't have time until Jan 6th or so (just before the final alpha). Does
that timeline work for you?

Sure, I think this is worth another look so let's wait. Let's just make sure we don't forget about this before the feature freeze.

Copy link
Contributor

@ncoghlan ncoghlan left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I like the patch overall, but there's one design concern I have, as well as a backwards compatibility concern:

  • for the backwards compatibility issue: calls using keyword arguments mean we can't arbitrarily change parameter names in public APIs
  • for the design question, implicitly supporting synchronous context managers in the asynchronous exit stack seems questionable to me.

The design question is one @1st1 and I talked about on the issue tracker (see https://bugs.python.org/issue29302#msg288735 and the next couple of comments), and after seeing the code in PR form, I definitely want to go with the more explicit API:

  • add separate *_sync variants of all the callback registration APIs in the async exit stack variant rather than trying to guess the user's intent based on the type of the object they passed in (if guessing proves desirable, we can add it later, but if we start with it, we're likely stuck with it even if it proves confusing)
  • avoid checking for awaitables when unwinding the stack in the async case (either add an awaitable wrapper to the synchronous callbacks as I suggest in this review, or else store a 2-tuple as @1st1 suggested on the tracker)

self.push(_exit_wrapper)

def push(self, exit):
def push(self, exit_obj):
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Folks may be calling stack.push(exit=obj), so we shouldn't gratuitously change parameter names.

@@ -4,9 +4,10 @@
import _collections_abc
from collections import deque
from functools import wraps
import inspect
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This introduces a dependency I'd prefer to avoid - inspect pulls in a lot of other modules, and contextlib is used frequently enough that we should aim to minimise its dependency tree.

# We look up the special methods on the type to match the with statement
_cm_type = type(cm)

# if you have both aenter + enter, aenter will 'win'
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This comment is oddly placed, and doesn't seem especially accurate - the check is being made against __aexit__, not __aenter__.

More generally, implicitly interleaving synchronous with asynchronous context managers seems dubious to me - while it might be a good idea to allow it, doing it automagically rather than explicitly seems like a recipe for confusion when reading and debugging code.

result = next(gen)
while 1:
try:
if inspect.isawaitable(result):
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

If we do decide to allow synchronous context managers in asynchronous exit stacks, I'd suggest wrapping their exit callbacks in an awaitable, so this check can be avoided.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

inspect is also used by _create_exit_wrapper and _create_cb_wrapper.

@bedevere-bot
Copy link

A Python core developer has requested some changes be made to your pull request before we can consider merging it. If you could please address their requests along with any other requests in other reviews from core developers that would be appreciated.

Once you have made the requested changes, please leave a comment on this pull request containing the phrase I have made the requested changes; please review again. I will then notify any core developers who have left a review that you're ready for them to take another look at this pull request.

@1st1
Copy link
Member

1st1 commented Jan 20, 2018

Couple of thoughts:

  1. I think that AsyncExitStack must support both sync and async context managers, otherwise it would be impossible to express code like below:
with Foo:
    async with Bar:
        with Ham:
            ...
  1. I'd it like to have enter_context methods for sync context managers, and enter_async_context for async context managers. This is explicit and verbose, yes, but it handles the weird case when an object implements both sync- and async- context managers. Python allows to do that, so we should handle this case instead of guessing.

  2. +1 once for removing inspect.isawaitable call. Instead, we should push tuples like (is_sync, callback) to _exit_callbacks. Otherwise if someone submits a callable that for whatever reason implements __await__, using isawaitable would result in a wrong guess and the callable would be awaited instead of being called.

@1st1
Copy link
Member

1st1 commented Jan 20, 2018

Also, we need to get this merged before Jan 29. @Kentzo if you don't have time to work on this in the next few days I can handle this PR myself.

@ncoghlan
Copy link
Contributor

ncoghlan commented Jan 20, 2018

@1st1 So the differences between AsyncExitStack and ExitStack would be:

  1. close() becomes a coroutine instead of a synchronous method
  2. it defines __aenter__ and __aexit__ instead of __enter__ and __exit__
  3. it has 3 new methods for callback registration (one coroutine, enter_async_context, and two synchronous methods, push_async_exit and push_async_callback)

I like that, since it means registering synchronous context managers and callbacks stays the same regardless of which kind of stack you're using.

A note regarding the method names: the synchronous method names are just push and callback. I think those are slightly problematic, since they're both push operations (making the first one ambiguous), and the latter isn't a verb (which is dubious for a method name). Since push_async and callback_async aren't clear on whether the operation itself is asynchronous, I see value in switching to the more explicit method names before adding the async qualifier: push_async_exit, push_async_callback.

@1st1
Copy link
Member

1st1 commented Jan 20, 2018

@1st1 So the differences between AsyncExitStack and ExitStack would be: [..]

Right.

I like that, since it means registering synchronous context managers and callbacks stays the same regardless of which kind of stack you're using.

Yeah, the API consistency for synchronous CMs is great. To be honest I haven't thought about it until you highlighted it, but now I see it as a requirement!

Since push_async and callback_async aren't clear on whether the operation itself is asynchronous, I see value in switching to the more explicit method names before adding the async qualifier: push_async_exit, push_async_callback.

+1.

@njsmith
Copy link
Contributor

njsmith commented Jan 20, 2018

Please name the close method aclose, for consistency with async generators. (This will also make AsyncExitStack a trio.abc.AsyncResource so long as all the items in it are themselves AsyncResources. But that's just because AsyncResource was designed to be consistent with async generators :-).)

Regarding the bikeshed, I think my preference FWIW is to make both sync and async explicitly marked, so it's e.g. enter_sync_context and enter_async_context, and there is no enter_context. This adds a small amount of hassle in the case where you have an existing ExitStack and then realize you want to mix in some async contexts as well, because you have to update existing calls. But it makes things much less confusing when you start out thinking "hmm, I have some async contexts that I need to put in a stack", so you make an AsyncExitStack and then are confused that AsyncExitStack.enter_context wants a synchronous context.

@asvetlov
Copy link
Contributor

@njsmith following this way we should add a prefix to all async functions everywhere: aclose(), asend(), arecv() etc.
The logic is weird, isn't it? I don't see how context manager is related to generator.

@njsmith
Copy link
Contributor

njsmith commented Jan 20, 2018 via email

@ncoghlan
Copy link
Contributor

ncoghlan commented Jan 20, 2018

@njsmith Good point regarding close() vs aclose() - I'd forgotten that part of PEP 525. Given that, I agree the method on AsyncExitStack should aclose(), and the synchronous close API should just be missing entirely (as with the other synchronous context management methods).

I'm not especially worried about folks having to sprinkle extra "async" mentions through their code to get async context managers to work as expected - that's the default language wide. For example, even though you've written stack = contextlib.AsyncExitStack(), you also have to write async with stack: - you can't just write with stack: the way you can with the synchronous version and have Python automatically figure out you must have wanted to use the async variant of the with statement.

By contrast, I'm definitely not keen on having the correctness of code like f = stack.enter_context(open(file_of_interest)) depend on whether or not "stack" is a regular exit stack or an asynchronous one.

This does mean that stack.push(async_cm_or_exit) and stack.callback(async_callback) may run into the "coroutine never awaited" scenario, but that's why we have the other issue about detecting unawaited coroutines. I'd also be amenable to having a check (potentially __debug__-only) in AsyncContextManager.__aexit__ itself for nominally synchronous callbacks returning awaitables, as that scenario is likely to inadvertently suppress exceptions as well (since a lot of awaitables are likely to be "True" by default).

@1st1
Copy link
Member

1st1 commented Jan 20, 2018

I agree with everything Nick said here.

@njsmith
Copy link
Contributor

njsmith commented Jan 21, 2018

👍

Copy link
Contributor

@ncoghlan ncoghlan left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This version looks good to me, but leaving to @1st1 to merge after his review :)

@ncoghlan
Copy link
Contributor

The Appveyor failures look unrelated to me - closing & reopening to check if they're transient errors.

@ncoghlan ncoghlan closed this Jan 23, 2018
@ncoghlan ncoghlan reopened this Jan 23, 2018
@1st1
Copy link
Member

1st1 commented Jan 23, 2018

I'll take a look today/tomorrow, thanks Nick!

@Kentzo
Copy link
Contributor Author

Kentzo commented Jan 23, 2018

@ncoghlan What do you think about adding push_exit and push_callback aliases for API symmetry?

@ncoghlan
Copy link
Contributor

@Kentzo Worth considering as a separate issue for 3.8, but I wouldn't rush into it for 3.7.

Copy link
Member

@1st1 1st1 left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

There're multiple formatting issues with the PR. Please fix the code to follow PEP 8. Reformat docstrings to have a short first line ended with a period, optionally followed by an empty line with more paragraphs.

Most importantly, I don't like the design of _shutdown_loop. I think we shouldn't use generator.send/throw here, I'd prefer to copy/paste the code which will make the code easier to read and maintain (generators are complicated!)

/cc @ncoghlan

Continuing the example for :func:`asynccontextmanager`::

async with AsyncExitStack() as stack:
connections = [await stack.enter_async_context(get_connection()) for i in range(5)]
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Please trim the lines in your to be max 79 chars wide.


An :ref:`asynchronous context manager <async-context-managers>` similar
to :class:`ExitStack` that can additionally combine other asynchronous
context managers and cleanup coroutine functions.
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I'd rewrite to:

An :ref:`asynchronous context manager <async-context-managers>`, similar
to :class:`ExitStack`, that supports combining both synchronous and 
asynchronous context managers, as well as having coroutines for 
cleanup logic.


.. method:: enter_async_context(cm)

Same as :meth:`enter_context` but expects an asynchronous context manager.
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Same as -> Similar to

.. method:: push_async_exit(exit)

Same as :meth:`push` but expects either an asynchronous context manager or
a coroutine function.
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

"or a coroutine function" -> "or a coroutine".


.. method:: push_async_callback(callback, *args, **kwds)

Same as :meth:`callback` but expects a coroutine function.
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

ditto

class ExitStack(AbstractContextManager):
"""Context manager for dynamic management of a stack of exit callbacks
class _BaseExitStack:
"""
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

First line of the docstring should not be empty. Reformat to

"""A base class for ExitStack and AsyncExitStack."""


Can suppress exceptions the same way __exit__ methods can.

Can suppress exceptions the same way __exit__ method can.
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Please keep and empty line after the first line of the docstring. I also recommend you to read https://www.python.org/dev/peps/pep-0257/.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@1st1 In that PEP there is no empty line after a doctstring inside def. Should I add this extra empty line for all functions in my PR?

Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Ilya, I mean this:

def foo():
    """First line
    A paragraph
    """
    code

should be formatted as this

def foo():
    """First line.

    A paragraph.
    """
    code

Copy link
Member

@1st1 1st1 Jan 24, 2018

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

The first line should be a complete sentence.

I'm not making these rules up -- there're tons of tools out there that expect this specific code style to extract/parse docstrings.

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Ah I see.

def _push_exit_callback(self, callback, is_sync=True):
self._exit_callbacks.append((is_sync, callback))

def _shutdown_loop(self, *exc_details):
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I don't like using generator.send/throw for this. I'd better copy/paste the code. Generators have a pretty complicated semantics (especially around closing) and sometimes have issues with keeping exceptions' tracebacks in tact.

@@ -494,6 +497,127 @@ def _fix_exception_context(new_exc, old_exc):
return received_exc and suppressed_exc


# Inspired by discussions on http://bugs.python.org/issue13585
class ExitStack(_BaseExitStack, AbstractContextManager):
"""Context manager for dynamic management of a stack of exit callbacks
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Put periods . at the end of all your sentences. Throughout the patch.

"""Async context manager for dynamic management of a stack of exit callbacks
For example:
async with AsyncExitStack() as stack:
connections = [await stack.enter_async_context(get_connection()) for i in range(5)]
Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Tabulation is off and many lines are longer than 79. Please make sure that your PR follows PEP 8.

@bedevere-bot
Copy link

A Python core developer has requested some changes be made to your pull request before we can consider merging it. If you could please address their requests along with any other requests in other reviews from core developers that would be appreciated.

Once you have made the requested changes, please leave a comment on this pull request containing the phrase I have made the requested changes; please review again. I will then notify any core developers who have left a review that you're ready for them to take another look at this pull request.

@Kentzo
Copy link
Contributor Author

Kentzo commented Jan 24, 2018

I have made the requested changes; please review again

@bedevere-bot
Copy link

Thanks for making the requested changes!

@1st1, @ncoghlan: please review the changes made to this pull request.

@1st1
Copy link
Member

1st1 commented Jan 25, 2018

Merged. Thanks so much Ilya!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

8 participants