-
-
Notifications
You must be signed in to change notification settings - Fork 9.6k
[String] renamed core classes to Byte/CodePoint/UnicodeString #33816
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Conversation
dbc9b44
to
054e599
Compare
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I like the new names a lot: ByteString
and UnicodeString
would be self-explanatory for most developers and only CodePointString
would need some explanation for some people (but that's normal ... this is a "complex" topic, so developers need to learn some terminology).
054e599
to
d54fd8d
Compare
d54fd8d
to
63c105d
Compare
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I like the new naming. In the original PR, I especially found the name BinaryString
problematic. If we look at the operations that this class allows, the class does not represent an arbitrary binary string, but a character string with some one-byte character encoding, e.g. ISO-8859-something. The new name reflects that better, imho.
…tring (nicolas-grekas) This PR was merged into the 5.0-dev branch. Discussion ---------- [String] renamed core classes to Byte/CodePoint/UnicodeString | Q | A | ------------- | --- | Branch? | master | Bug fix? | no | New feature? | no | Deprecations? | no | Tickets | - | License | MIT | Doc PR | - In #33553 there have been discussions about the naming of the classes - eg. "what's a grapheme", "why `Utf8String`", "lowercase on binary is weird", etc. What about these names? Would they get your votes *vs* the current ones? - `BinaryString` -> `ByteString` - `Utf8String` -> `CodePointString` - `GraphemeString` -> `UnicodeString` Commits ------- 63c105d [String] renamed core classes to Byte/CodePoint/UnicodeString
In #33553 there have been discussions about the naming of the classes - eg. "what's a grapheme", "why
Utf8String
", "lowercase on binary is weird", etc.What about these names? Would they get your votes vs the current ones?
BinaryString
->ByteString
Utf8String
->CodePointString
GraphemeString
->UnicodeString